Регистрация...

Eserv Forum / E2 / Eserv 2 support (en) / SMTP forwarding (SPAM)

imported // (v1)
Продукты и услуги Скачать Документация Купить Поддержка Форумы Партнёрам Статьи О компании
Новости
12.10.2009
Переезд завершен
Hi,
The way I use Eserv for email is as follows.
My email@address.com is forwarded directly to my Eserv server from outside so no retrieving pop3 email! (Fine)
Internal email is sent to Eserv and sent either locally or externally. (Fine)

Everything works fine and it does not forward spam.

When I add 0.0.0.0 0.0.0.0 to the AllowConnectionsFrom to allow access to ftp the SMTP server starts forwarding spam!

Any ideas ?

Thankyou,
Wayne
 
Комментарии к этой версии (06.03.2003 11:47) [~wayne_] 360cfaea
АвторДатаТекстtags
pig06.03.2003 14:56
  1. Disable RelayAlienMail in the MailServerSMTPServer
  2. Enable CheckLocalConformity in the MailServerSMTPServer
  3. Set proper IPs in the LocalNetworks under the MailServerSMTPServer
  4. Disable Socks proxy or force autentification at Socks proxy in the ProxyServerSocksProxy
  5. Disable HTTP server and HTTP proxy or set proper access rights for http://, ftp:// and connect: objects in the CommonSettingsAccessRights.
imported
wayne_07.03.2003 12:16
RelayAlienMail is Disabled!
CheckLocalConformity is Enabled!
I have proper IP addresses in both LocalNetworks and AllowConnectionsFrom!

Why should disabling Socks and HTTP affect SMTP ?
And what do you mean about setting "propper" access rights ?

Wayne
imported
pig07.03.2003 13:41
wayne_ пишет: I have proper IP addresses in both LocalNetworks and AllowConnectionsFrom!

Hope, there is no 0.0.0.0 0.0.0.0 record in the LocalNetworks?

wayne_ пишет: Why should disabling Socks and HTTP affect SMTP ?

Nowadays, spammers often use Socks and HTTP proxy to access SMTP server from localhost loopback address 127.0.0.1. So, you should deny proxy access from outside using authentification at proxy. This also will prevent your server from blacklisting as Open Proxy.

wayne_ пишет: And what do you mean about setting "propper" access rights ?

The proper access rights is as following:
http:// -> AllUsers 1 ftp:// -> AllUsers 1 connect: -> AllUsers 1

I also recommend you to configure access to FTP proxy. You should set access rights for FTPGATE object (AllUsers 1, for example). Unfortunately, you should set up IP-Authorization to do this. But if you run Eserv on your home computer there will no big problem to set it up.
imported
wayne_07.03.2003 14:46
Hope, there is no 0.0.0.0 0.0.0.0 record in the LocalNetworks?

There is not.

I did not realise some of the issues you have pointed out with regards to access rights and Eserv. I will when I get the chance do some testing but will have to leave FTP disabled for now.

Thankyou for your help,
Wayne
imported
Работает на Eserv/5.05555 (05.06.2016)