Регистрация...

Eserv Forum / E5 / Mail / Перенос на другой сервер

recent wikipost // (v2)
Продукты и услуги Скачать Документация Купить Поддержка Форумы Партнёрам Статьи О компании
Скопировал папку с eserv5 на другой сервер (windows server 2016 std), при установке сервисов imap и smtp ругалось (см. картинку), но сервисы установились.

Снимок
 
Комментарии к версии 1 (14.11.2018 12:40) [~v753box] 52dcc9a3
Комментарии к этой версии (14.11.2018 12:41) [~v753box] e895c396
АвторДатаТекстtags
ac14.11.2018 21:16
А других вариантов этих dll нет на этой машине? Похоже на конфликт между версиями.

Eserv по именам привязывается к функциям dll, а не по номерам...

v753box пишет: но сервисы установились.

И SSL работает?
wikipost
v753box30.11.2018 12:12
И SSL работает?
Как проверить?
wikipost
pig30.11.2018 18:22
У меня тихое подозрение, что это имеющаяся libssl32.dll в чём-то несовместима с 2016 сервером. Ищет там что-то (старую нестойкую функцию шифрования?), чего в системе нет.
Вот тут предлагают свежую сборку OpenSSL под Windows 10, из неё можно попробовать выдернуть новые библиотеки.
wikipost
ac01.12.2018 23:27
ред: 01.12.2018 23:32
pig пишет: У меня тихое подозрение, что это имеющаяся libssl32.dll в чём-то несовместима с 2016 сервером.

Испытывал с 2016, несколько лет один из наших Eserv-серверов в MS Azure работал сначала Windows Server 2012, затем 2016. В этом году переведён на бету Windows Server 2019 (там же на MS Azure), работает нормально: https://2019.eserv.ru/ — openssl-библиотеки там 2011 года, из "штатного" комплекта Eserv.

pig пишет: Вот тут предлагают свежую сборку OpenSSL под Windows 10, из неё можно попробовать выдернуть новые библиотеки.

Скорее всего не заработает в текущей версии Eserv. Свежие библиотеки openssl я использовал недавно вот в этой программе генерации сертификатов через LetsEncrypt: http://forum.eserv.ru/E4/Mail/Пересоздать SSL сертификат, автосозданный при установке — из-за несовместимости с изменениями API openssl пришлось именно делать отдельный модуль (тоже на форте, но с изменениями в библиотеках), а не встраивать в виде plugin'а в Eserv.
wikipost
v753box18.10.2019 12:41
Перекинул на 2019, такая же картинка при установке сервисов. При этом работает (SSL не исп.).
wikipost
Работает на Eserv/5.05555 (05.06.2016)