Регистрация...

Eserv Forum / Talks / Any / Не хватает указания charset в письмах

imported // (v1)
Продукты и услуги Скачать Документация Купить Поддержка Форумы Партнёрам Статьи О компании
Новости
01.10.2009
PhpBB скоро выключим
Пришло мне автоизвещение на русском языке, а кодировка не указана. Хорошо, что никто восьмой бит не съел по дороге, только OE решил (по умолчанию, как у меня установлено), что это КОИ8 вместо Windows-1251.
 
Комментарии к этой версии (12.01.2002 00:42) [~pig] e3e20336
АвторДатаТекстtags
ac12.01.2002 13:38
Да. Но тему показывает при этом почему-то верно (у меня MS Outlook). Указание кодировки в phpBB вставить несложно, но там общий код для русских писем и для буржуйских, им будет предлагать кириллицу устанавливать. Может просто вставить там конвертацию письма в KOI8? На английском тексте это не скажется.
imported
ac14.01.2002 00:12
тест
imported
admin14.01.2002 00:28
тест
imported
ac14.01.2002 01:16
Сделал конвертацию писем в koi8, вроде теперь нормально.
imported
pig14.01.2002 10:40
Я, когда писал LankLink (http://lanklink.virtualave.net/), кодировку писем-извещений просто увязал с языком, на котором они генерились.
imported
ac14.01.2002 12:39
Да, вставлять заголовок с указанием кодировки — это правильно. Но в phpbb для этого надо вставить несколько новых строк кода — выяснение языка получателя и т.п., а сильно курочить её не хочется (т.к. скоро выйдет релиз, и все исправления в него вносить заново). Поэтому я просто добавил convert_cyr в функцию отправки письма — на английские письма это не повлияет, а русские все идут в koi8, что современные почтовые клиенты показывают автоматом верно. Или что-то не так в приходящих письмах?
imported
ac14.01.2002 12:42
Кстати, с lanklink'ом что-то не то:
http://lanklink.virtualave.net/msk/cgi-bin/UMarket.cgi?a=select&n=003&k:001=0000&k:002=0001&l=RU дает ошибку 500.
imported
pig14.01.2002 13:22
Пристрелить бы его, чтоб не мучился Всё равно никто не хочет вкладываться в развитие идеи. А он, бедогала, болтается там пока как иллюстрация концепции. Опять, наверное, в DBM-файле что-то поломалось

А с письмами всё в порядке.
imported
Anonymous07.09.2002 01:35
?, ... ? ? phpbb2.0.2 ?.. ?

:
"
? SMTP
, / ? SMTP, ? ? ?[\b] (\?)"
? ? ?[\b] ? ? - sendmail? ? ? ? ? ?

? ?
imported
Работает на Eserv/5.05555 (05.06.2016)