Регистрация...

Eserv Forum / E5 / Mail / Не уходят письма наружу-лежат в папке OUT

recent wikipost // (v1)
Продукты и услуги Скачать Документация Купить Поддержка Форумы Партнёрам Статьи О компании
Перевела Eserv на новый комп — Win 10. Просто скопировала все дерево на диск с той же буквой. Все сразу заработало, но иногда всплывают какие-то непонятки. Вот, напр., сегодня вдруг перестала уходить наружу почта. Без всяких предупреждений. Т.е. письма складируются в E5\Data\mail\out\ и там лежат. До этого момента все уходило/приходило норм. Попробовала перезапустить acSMTP. Не помогло. Тогда остановила все acWEB, acSMTP, acIMAP/ И запустила их снова (в обратном порядке). Письма ушли, папка опустела. Через полчаса ситуация повторилась . В E5\Data\temp\2021-02-11\ лежат файлики только про уже отправленные письма. Никаких попыток неудачных отпраок нет. Пересмотрела все логи, все ок, без ошибок. Какие-то флажки что ли не взводятся при попадании письма в OUT?
Еще одна странность — не показываются соединения в веб-панели управления. просто пустая таблица справа. Один раз показались соединения в разделе прокси, но потом их перестало показывать.
Отличия старого компа от нового — другая ОС (была XP), другие диски (SSD), и не стала заводить комп в домен, оставила в раб.группе. Файерволл виндовский отключен.
Что я делаю не так? Куда смотреть хоть?
 
Комментарии к этой версии (11.02.2021 15:54) [~matveeva] 15046f56
АвторДатаТекстtags
matveeva11.02.2021 16:36
Вот сейчас еще странная ситуация. После останова/запуска служб пачка писем ушла, все ок, без ошибок. Затем минут через пять появились в out новые два письма и лежали там почти полчаса, потом сами ушли. Похоже, как по расписанию раньше почта забиралась с внешних серверов. Но не было же никаких настроек на эту тему?
Посмотрела Temp за предыдущие дни — там письма по одной штуке уходили, не через полчаса, а, видимо, по мере поступления.
wikipost
matveeva11.02.2021 17:53
Ну да. Через полчаса уходят сами пачкой. Так ведь нет планировщика на это? Откуда полчаса-то взялось? Еще утром все норм было.
wikipost
ac12.02.2021 02:20
Планировщик на повторы есть (встроенный, чтобы не ломали случайно). Пауза в ini в SchedulerRetryPause.

А почему сразу не уходят — интересный вопрос. Проверьте, что указано в SmtpSendOutbound — может там несуществующее (после переезда) размещение smtpsend'а?
wikipost
ac12.02.2021 02:23
matveeva пишет: Еще одна странность — не показываются соединения в веб-панели управления. просто пустая таблица справа. Один раз показались соединения в разделе прокси, но потом их перестало показывать.


А в разделе "Система/сеть/соединения/активные" есть?
wikipost
matveeva12.02.2021 11:43
ac пишет: Планировщик на повторы есть (встроенный, чтобы не ломали случайно). Пауза в ini в SchedulerRetryPause.

Без изменений, в E4.orig.ini
SchedulerPause=180000 SchedulerRetryPause=3600000

ac пишет: Проверьте, что указано в SmtpSendOutbound — может там несуществующее (после переезда) размещение smtpsend'а?

[Delivery] SmtpSendOutbound="smtpsend4.exe -dd -dw -ln 200 -r 2 -helo {Server[HostName]} -rd {SMTP[Out]}\127.0.0.1\{SMTP[Port]} -ra {Server[AdminEmail]} -rf {SMTP[RetryOutbound]}\"

Но эта строка не менялась давно уже. И, если с ней что-то было быне так, вообще вся почта не уходила бы. А тут какие-то случайный задержки. Вот, напр., как ввчера все происходило — это содержимое папки Temp
11.02.2021 07:28 outbound-2248!103213156!3_log.xml 11.02.2021 09:09 outbound-2339!109273671!3_log.xml 11.02.2021 09:11 outbound-2342!109441453!4_log.xml 11.02.2021 09:11 outbound-0!109450656!1_log.xml 11.02.2021 09:17 outbound-2347!109786343!3_log.xml 11.02.2021 09:36 outbound-2369!110915187!3_log.xml 11.02.2021 09:36 outbound-2368!110914562!3_log.xml 11.02.2021 09:56 outbound-2387!112115046!3_log.xml 11.02.2021 14:22 outbound-0!128003031!1_log.xml 11.02.2021 14:39 outbound-23!129093437!3_log.xml 11.02.2021 14:40 outbound-25!129182546!3_log.xml 11.02.2021 14:42 return-0!129263062!1.xml 11.02.2021 14:48 outbound-0!129623062!1_log.xml 11.02.2021 [b] 15:55[/b] outbound-0!133640562!1_log.xml 11.02.2021 [b] 16:22[/b] outbound-0!135260578!1_log.xml 11.02.2021 [b] 17:08[/b] outbound-58!138037359!3_log.xml 11.02.2021[b] 17:52[/b] outbound-0!140660625!1_log.xml 11.02.2021 18:15 outbound-112!142062578!3_log.xml 11.02.2021 18:28 outbound-124!142855890!3_log.xml 11.02.2021 18:34 outbound-128!143179375!3_log.xml 11.02.2021 18:34 outbound-0!143180656!1_log.xml 11.02.2021 18:54 outbound-139!144381375!3_log.xml 11.02.2021 19:32 outbound-164!146659812!3_log.xml 11.02.2021 19:36 outbound-170!146920265!3_log.xml 11.02.2021 20:18 outbound-200!149423812!3_log.xml 11.02.2021 20:19 return-0!149480734!1.xml 11.02.2021 20:19 outbound-202!149514687!3_log.xml
Видно, где переход на получасовую отправку. А дальше, вроде, пошло все норм, по мере поступления.
Сейчас вот опять пара писем лежит.: одно в 11:23, второе в 11:34 сделаны. Пока лежат (сейчас 11:45).
Вот, кстати, посмотрела. Уходят без ожидания письма, которые по фильтру перенаправляются на внешние адреса (есть несколько сотрудников, которые просили дублировать им входящую почту на личные ящики). Вот эти письма не ждут. А сделанные руками — лежат. Может, закономерности тут нет, и просто совпадение.
ac пишет: А в разделе "Система/сеть/соединения/активные" есть?

В тот момент нигде не было, в т.ч. и в активных. Сейчас тоже пустая таблица.
wikipost
matveeva12.02.2021 12:02
matveeva пишет: Сейчас вот опять пара писем лежит.: одно в 11:23, второе в 11:34 сделаны. Пока лежат (сейчас 11:45).
Ну, вот уже 12:04, все так и лежит. Так что не через полчаса.
wikipost
matveeva12.02.2021 12:16
matveeva пишет: Уходят без ожидания письма, которые по фильтру перенаправляются на внешние адреса (есть несколько сотрудников, которые просили дублировать им входящую почту на личные ящики). Вот эти письма не ждут. А сделанные руками — лежат. Может, закономерности тут нет, и просто совпадение.
Нет. Тут что-то другое. Сделала сейчас пару таких писем, все перенаправленные легли в OUT ко всем остальным. Так и лежат. Так что здесь что-то другое влияет... Где еще смотреть — не знаю. На компе в журналах никаких событий не наблюдается.
wikipost
matveeva12.02.2021 12:23
И еще странность. Не помогает перезапуск служб. Ни одной, ни по очереди всех трех. Не помогает осановить/запустить службы по одной. Не помогает остановить обе службы acIMAP, acSMTP, а потом их обе запустить. Только остановить все три, а потом все три запустить. Вот после запуска acWEB все и начало отправляться.
wikipost
matveeva12.02.2021 12:58
matveeva пишет: Не помогает осановить/запустить службы по одной.
Неправа. Помогает останов и запуск acWEB . Письма так и не уходят сами (
wikipost
matveeva12.02.2021 13:19
вдруг неожиданно все стало отправлять само, и стали видны соединения в т.ч. активные. Чудесатее и чудесатее...
wikipost
matveeva12.02.2021 14:39
Продолжаю наблюдения...
В 13:52 было нормально отправлено письмо, и в этот же момент (ну, примерно) перстали показываться соединения. А след. письмо — в 14:08 уже зависло. И папка стала заполняться почтой, пока не остановила и заново запустила acWEB. Просто "Перезапустить службу" не играет. Со службами работаю через оснастку "управление компом" с самого прокси.
Кстати, на новом компе теперь после завершения сеанса юзера, не приходится перезапускать acFilter и Popfile, они продолжают работать.
wikipost
ac14.02.2021 20:59
ред: 14.02.2021 21:00
matveeva пишет: Видно, где переход на получасовую отправку. А дальше, вроде, пошло все норм, по мере поступления.

Эти логи outbound-RANDOM-ID_log.xml создаются как раз по мере поступления писем в папке OUT — сразу после получения письма на отправку оно перемещается в OUT и запускается smtpsend4 с выводом в лог outbound*.xml. Если отправить не получилось, то в логе будет указана причина неотправки каждого из писем, ожидающих на тот момент в OUT.

Логи повторных попыток, запускаемых планировщиком (каждые три минуты при таких настройках) имеют другие имена — retry-RANDOM-ID.xml. Есть такие?

matveeva пишет: Сейчас вот опять пара писем лежит.: одно в 11:23, второе в 11:34 сделаны. Пока лежат

Тогда стоит почитать outbound*.xml, созданные в то же время и позднее.

Проверьте еще, нет ли запущенных процессов smtpsend4.exe в тот момент, когда почта не уходит.

matveeva пишет: Не помогает перезапуск служб.

Чему он должен помочь, для чего перезапуск? Форсировать отправку? Планировщик в службе acSMTP.

matveeva пишет: Куда смотреть хоть?

Коды ошибок в логах *.xml.
wikipost
ac14.02.2021 21:04
matveeva пишет: В тот момент нигде не было, в т.ч. и в активных. Сейчас тоже пустая таблица.


А если при пустой таблице запустить
netstat.exe -onap TCP
— есть в списке соединения в статусе ESTATBLISHED?
wikipost
matveeva14.02.2021 22:29
ac пишет: Эти логи outbound-RANDOM-ID_log.xml создаются как раз по мере поступления писем в папке OUT — сразу после получения письма на отправку оно перемещается в OUT и запускается smtpsend4 с выводом в лог outbound*.xml.
В ситуации, которую я описываю, новые файлы в Temp не появляются, хотя в OUT лежит десяток писем и долго. Соответственно, ни о каких ошибках нигде не пишется.
ac пишет: Логи повторных попыток, запускаемых планировщиком (каждые три минуты при таких настройках) имеют другие имена — retry-RANDOM-ID.xml. Есть такие?
Нет.
ac пишет: Тогда стоит почитать outbound*.xml, созданные в то же время и позднее.
Там только один файл получается при остановке/запуске acWeb, в котором по очереди отправляются все письма. Отправляются норм, без ошибок.
ac пишет: Проверьте еще, нет ли запущенных процессов smtpsend4.exe в тот момент, когда почта не уходит.
Ок, поняла, посмотрю. Все выходные периодически заглядываю в OUT, там каждый раз пусто )))
ac пишет: Коды ошибок в логах *.xml.
Там нет ошибок.
ac пишет: А если при пустой таблице запустить netstat.exe -onap TCP
— есть в списке соединения в статусе ESTATBLISHED?
Завтра проверю )
wikipost
ac14.02.2021 23:49
matveeva пишет: В ситуации, которую я описываю, новые файлы в Temp не появляются

Значит что-то с запуском smtpsend. Один из вариантов не-запуска, точнее запуска с завершением без создания лога — это если уже запущено 20 экземпляров smtpsend: если они заняты чем-то длительным, например отправкой большого числа писем, или при сетевых проблемах небольшое число писем едет "туго". Smtpsend запускается, насчитывает 20 "братьев", решает "без меня справятся, нечего тут толпиться" и завершается.
wikipost
matveeva15.02.2021 13:09
ac пишет: Один из вариантов не-запуска, точнее запуска с завершением без создания лога — это если уже запущено 20 экземпляров smtpsend: .
Понаблюдаю за наличием нескольких экземпляров smtpsend в процессах диспетчера задач.
ac пишет: если они заняты чем-то длительным, например отправкой большого числа писем, или при сетевых проблемах небольшое число писем едет "туго"
В первый такой инцидент предыдущее письмо ушло нормально, никаких ошибок в outbound*.xml не было. А вот следующие письма уже не отправлялись, а накапливались в OUT. Никаких *.xml в Temp не создавалось в это время.
А если при пустой таблице запустить netstat.exe -onap TCP — есть в списке соединения в статусе ESTATBLISHED?
Да, полно. И с внутренними адресами, и с внешними.
wikipost
matveeva15.02.2021 13:29
Ну вот сейчас опять восемь минут лежит письмо. Перед этим за пару минуту до этого ушло норм. Никаких процессов smtpsend нет вовсе (смотрела в диспетчере задач: вкладки Процессы, Подробности). Уже 18 мин прошло, письма лежат...
wikipost
matveeva15.02.2021 14:20
Прошло больше часа. После перезапуска acSMTP и acWEB (остановить — запустить) появился процесс smtpsend4, который шустро отправил накопившиеся пять писем и схлопнулся. И что это было...
wikipost
ac16.02.2021 00:32
ред: 16.02.2021 00:33
Запустите консоль cmd.exe в папке acSMTP (или FAR'ом войдите), и там запустите

smtpsend4.exe -test
— запустится ли, будет ли что-нибудь подозрительное в выводе?
wikipost
ac16.02.2021 00:37
matveeva пишет: Да, полно. И с внутренними адресами, и с внешними.

Может тогда попробовать, остановив службу acWEB, запустить acWEB5.exe простой программой вручную и заглянуть в http://127.0.0.1:2012/e4i/eserv.htm — в таком режиме будут соединения?
wikipost
matveeva19.02.2021 10:33
Прошу прощения за паузу.
ac пишет: smtpsend4.exe -test
— запустится ли, будет ли что-нибудь подозрительное в выводе?
На мой взгляд нормальный вывод:
E5\acSMTP>smtpsend4.exe -test <?xml version='1.0' encoding='windows-1251'?> <?xml-stylesheet href='atom.xsl' type='text/xsl'?> <feed version='0.3' xmlns='http://purl.org/atom/ns#' xmlns:s='http://www.eserv.ru/smtpsend/log'> <title>SMTPSEND v4.78 log</title> <modified>2021-02-16T14:42:43Z</modified> <author><name>smtpsend4 at aori.co.ru</name></author> <!-- -test --> <s:dns>Checking DNS settings. Server: 192.168.16.1 DNS settings seem OK</s:dns> <entry> <link rel='alternate' type='message/rfc822' href='support@eserv.ru!1' /> <id><![CDATA[13128$561337875$1@eserv.ru]]></id> <author><name>Eserv Support</name><email>support@eserv.ru</email></author> <summary>To: smtpsend4@gmail.com</summary> <title>[smtpsend4] ¤Єю ЄхёЄ 561337875</title> <s:to>smtpsend4@gmail.com</s:to> <s:mx>MX: gmail-smtp-in.l.google.com</s:mx> <content type='text/plain'><![CDATA[ 220 mx.google.com ESMTP f10si12056655ljo.110 - gsmtp HELO ADSL 250 mx.google.com at your service MAIL FROM:<support@eserv.ru> 250 2.1.0 OK f10si12056655ljo.110 - gsmtp RCPT TO:<smtpsend4@gmail.com> 250 2.1.5 OK f10si12056655ljo.110 - gsmtp DATA 354 Go ahead f10si12056655ljo.110 - gsmtp Message-ID: <13128$561337875$1@eserv.ru> Date: Tue, 16 Feb 2021 14:42:43 +0300 From: "Eserv Support" <support@eserv.ru> To: smtpsend4@gmail.com Subject: [smtpsend4] -L¦ L+LL 561337875 Content-Type: text/plain; charset=koi8-r Content-Transfer-Encoding: 8bit щ-+г+гL+, L+LL 561337875. . Send bps=6872 250 2.0.0 OK 1613475780 f10si12056655ljo.110 - gsmtp QUIT 221 2.0.0 closing connection f10si12056655ljo.110 - gsmtp ]]></content> <s:ior>Ok</s:ior> <s:result>SUCCESS</s:result> </entry> <s:exit>Exit OK</s:exit></feed>
Вообще я сделала батник, которым можно вручную запустить отправку — работает норм. Хотела его в планировщик поставить, пока не разобрались в причине, но почему-то из планировщика не срабатывает. Поэтому пока периодически проверяю наличие писем в OUT и запускаю ручками, если надо. Позавчера делала так раза три, вчерашний день все само нормально уходило. Закономерности пока не могу уловить. Мож, какие дополнительные отладочные выводы сделать?
ac пишет: Может тогда попробовать, остановив службу acWEB, запустить acWEB5.exe простой программой вручную и заглянуть в http://127.0.0.1:2012/e4i/eserv.htm — в таком режиме будут соединения?
Пока не было возможности это сделать, т.к. удаленно работала.
wikipost
matveeva19.02.2021 11:54
ред: 19.02.2021 11:58
Предположение в порядке бреда — пытаюсь уловить хоть какую закономерность...
Сегодня вот с утра сломалось и не чинится. Не связано ли это с работой моего компа, на котором все время открыт Outlook с настроенными папками IMAP ко всем "техническим учеткам"(папки для спама, для чистой почты, архивы)? Вчера, напр., мой комп не работал, и сбоев не было. Но бывали ситуации, когда все работало норм и при работающем моем компе. Была у меня еще в Хроме вкладка управления Eserv-ом, но там в основном просто висел запрос логина-пароля, редко туда заходила. Сейчас эту вкладку на всякий случай закрыла.
Пока приходится периодически заходить на комп с прокси и запускать батник с smtpsend — нормально отрабатывает.
wikipost
ac21.02.2021 01:31
matveeva пишет: Не связано ли это с работой моего компа, на котором все время открыт Outlook с настроенными папками IMAP ко всем "техническим учеткам"(папки для спама, для чистой почты, архивы)?

Нет, IMAP не может мешать запуску процессов из acSMTP.

А вот то, что не smtpsend не запускается из планировщика в acWEB также как не запускается из acSMTP подкрепляет желание испытать запуск этих служб обычными программами. Или перенастройку служб на работу с правами пользователя (вашего системного логина), а не system. Возможно дело в правах доступа.

Недоступность списка соединений в интерфейсе acWEB тоже может быть из-за этого...

Правда тогда (если дело в правах) непонятно, почему иногда оно всё же работает само.
wikipost
matveeva21.02.2021 11:38
ред: 21.02.2021 13:34
Так в итоге, что делаем? Мониторила вчера весь день и сегодня — все норм. Но вчера и сегодня никто не работал в офисе, вся исходящая почта — только перенаправленная правилами. Вся беда происходит только при работающем офисе.
Работать с acWEB могу очень ограниченно, потому что подключаюсь удаленно.
И есть ли какая-нибудь возможность более оперативного общения? А то надолго процесс может растянуться... )
Спасибо!
wikipost
ac21.02.2021 15:21
matveeva пишет: Так в итоге, что делаем?

Запустить acSMTP и acWEB под своей учетной записью — обычными программами или перенастройкой служб с system на свою учетную запись.

matveeva пишет: Пока приходится периодически заходить на комп с прокси и запускать батник с smtpsend

Если так работает, то батник можно зациклить с интервалом в минуты три, заходить не придётся.
wikipost
matveeva21.02.2021 17:37
ac пишет: Запустить acSMTP и acWEB под своей учетной записью — обычными программами или перенастройкой служб с system на свою учетную запись.
Запустила только acSMTP (acWEB боюсь удаленно трогать). Пробное письмо ушло само.
ac пишет: Если так работает, то батник можно зациклить с интервалом в минуты три, заходить не придётся.
Была мысль в виндовский планировщик его запустить, но подумала, что вдруг пересекутся с иногда работающим правильно встроенным. И будут друг у друга хлеб отнимать
wikipost
matveeva22.02.2021 23:52
matveeva пишет: Запустила только acSMTP
Пока сбоев не было, но и в офисе народа нет, все письма пока только автопересылка.
wikipost
matveeva24.02.2021 18:24
Вчера, 23/02/2021, в офисе работал только мой комп с запущенным аутлуком, все норм, сбоев не было.
Сегодня, 24/02/2021, офис целый день отработал без сбоев (свой комп не включала). Продолжаем наблюдение
wikipost
matveeva26.02.2021 15:26
Хотела еще с утра отчитаться, что у меня пока все работает ))) Вплоть до сейчас в OUT пусто. На своем компе тоже ограниченно работала. Пока норм. Продолжаем полет
wikipost
ac27.02.2021 02:26
matveeva пишет: вдруг пересекутся с иногда работающим правильно встроенным. И будут друг у друга хлеб отнимать

Они умеют это мирно разруливать.

matveeva пишет: Хотела еще с утра отчитаться, что у меня пока все работает )))

Выходит, дело было в правах доступа. Хотя и не понятно, почему иногда всё равно работало раньше.

А в вашей сети есть централизованный ActiveDirectory, или все права локально на этом сервере управляются?
wikipost
matveeva27.02.2021 13:04
ac пишет: А в вашей сети есть централизованный ActiveDirectory, или все права локально на этом сервере управляются?
Есть, и старый прокси был в домене. А новый комп я решила в домен не вводить. Как-то мне это более безопасным показалось. Поэтому он в раб.группе обычной, на компе один пользователь-администратор — я. Но странно, что у системной записи прав меньше, чем у администратора? И совершенно точно оно работало. А в какой-то момент ломалось. Непонятно. В общем, пока оставляю службу acSMTP работать под своей учеткой. acWEB не трогала. Буду смотреть, как идет. Но хотелось бы разобраться, потому что невыясненная причина может неожиданно сыграть в какой-то момент.
Спасибо!
wikipost
Работает на Eserv/5.05567 (10.02.2020)