Регистрация...

Eserv Forum / E3 / Eserv 3 Web and FTP Servers Support / Не запускается Веб интерфейс управления сервером после обнов

imported // (v1)
Продукты и услуги Скачать Документация Купить Поддержка Форумы Партнёрам Статьи О компании
Новости
12.10.2009
Переезд завершен
Всем привет

Возник вопрос по поводу Веб интерфейса.
С утра обновил версию до 3.22 и теперь влоге AcWeb выдаётся следующая ошибка —
Thu, 04 Aug 2005 13:14:13 +0400 MaxSPoolLen reached!
Соответственно он не запускается.

[HTTP]
Port=80
PhpBin=c:\php\php.exe
PerlBin=c:\perl\perl.exe
AdminUser=admin
AdminPass=ххххххххххххххххххх

Про админский порт и интерфейс данные берутся из orig.ini
 
Комментарии к этой версии (04.08.2005 12:31) [~Evguenil] 48bcbe07
АвторДатаТекстtags
pig04.08.2005 13:04
Попробуйте http://bitrix.eserv.ru/download/acWEB.exe. Не знаю, что там поменялось, но он закачан позже, чем дистрибутив.
imported
pig04.08.2005 13:10
Нет. То есть, правленный acWEB можете попробовать, но можно просто закомментировать строку с волшебным словом UsePool в acWEB\conf\OnStartup.rules.txt.
imported
Evguenil04.08.2005 13:30
Спасибо
Правленный acWEB вроде помог.
Стал запускаться нормально и на 80 и на админском.
Предыдущий работал то на дном то на другом порту.
Дир ни как не мог на веб почту попасть
imported
ac04.08.2005 17:50
pig пишет: Нет. То есть, правленный acWEB можете попробовать, но можно просто закомментировать строку с волшебным словом UsePool в acWEB\conf\OnStartup.rules.txt.


Ой. UsePool не должен был в дистрибутив выскочить, не уследил Перезакачаю дистрибутив.

Свежий отдельный acWEB — просто отладочная версия, ничего там не поменялось, это я для установки на сервер закачал (на ней сейчас и сидим).

Как у вас сразу при запуске очередь пула успевает заполниться.. непонятно. У вас там мог кто-то при перезапуске активно ломиться на порты acweb? Там на входе две очереди — одна на слушающем сокете (1000 запросов по умолчанию), вторая та что у вас исчерпалась (20 запросов по умолчанию). Мне такое быстро исчерпать удавалось только стресс-тестом.

У кого-нибудь еще такое случилось?
imported
Gena05.08.2005 13:42
У кого-нибудь еще такое случилось?

Да, интерфейс администратора периодически не работает. помогает перезапуск

в asWeb.log много записей
Fri, 05 Aug 2005 12:24:40 +0400 MaxSPoolLen reached!

никакой нагрузки на web нет.
imported
ac05.08.2005 15:59
А можно попросить запустить в этой конфигурации, когда такая ругань в логе идет, следующее:

utils\snmp-mon.exe -data localhost:3140:eserv_monitor:1.3.6.1.4.1.18474.2.1.3.1.1 -height 30 -max 20 -title "Длина очереди"

Какое значение счетчика показывает в начале? И какое в момент появления ругани в логе?

Кстати, отключение UsePool без замены acWEB помогает или нет?
imported
Gena05.08.2005 18:18
Кстати, отключение UsePool без замены acWEB помогает или нет?

Помогает. Пока все работает нормально. acWEB не менял. Лог чистый
utils\snmp-mon.exe -data localhost:3140:eserv_monitor:1.3.6.1.4.1.18474.2.1.3.1.1 -height 30 -max 20 -title "Длина очереди"

Ну если только в понедельник.
imported
ac05.08.2005 19:12
Gena пишет: Ну если только в понедельник.

ОК, спасибо.
imported
Gena06.08.2005 21:15
utils\snmp-mon.exe -data localhost:3140:eserv_monitor:1.3.6.1.4.1.18474.2.1.3.1.1 -height 30 -max 20 -title "Длина очереди"

Какое значение счетчика показывает в начале? И какое в момент появления ругани в логе?

В начале 0, затем в какой-то момент времени, закономерность не обнаружил, после запроса все подвисает, страничка не выводится, счетчик увеличивается на 1, и после следующего еще на 1 и так пока не достигнет 20, затем ругань в логе.
Происходит это не всегда, когда все работает, добится увеличения счетчика до 20 нереально.
Никакой нагрузки на сервер нет, я один. При закоментаренном UsePool все нормально.
imported
ac07.08.2005 00:55
Спасибо за репорт! Буду вычислять этот баг.
imported
ac07.08.2005 00:58
ac пишет: Спасибо за репорт! Буду вычислять этот баг.

Кстати, когда "после запроса все подвисает" — это запрос к веб-интерфейсу? А не замечали в taskmgr — не висит ли при этом в памяти fs.exe? И сколько потоков показывает taskmgr в acWEB?
imported
Gena07.08.2005 09:45
Кстати, когда "после запроса все подвисает" — это запрос к веб-интерфейсу?

Да, просто щелчек по меню в интерфейсе администратора.
А не замечали в taskmgr — не висит ли при этом в памяти fs.exe?

Один раз висел, с 8 потоками. Один раз при зависании в taskmgr его не было. Связи fs.exe с зависаниями не нашел.
И сколько потоков показывает taskmgr в acWEB?

При запуске 7, после зависания 11, иногда 14. При обычной работе ситуация такая же.
imported
ac15.08.2005 22:27
Если не затруднит, испытайте, пожалуйста, новый http://www.eserv.ru/download/acWEB.exe в режиме UsePool — вылечилась проблема или нет (Рувим нашел, где у меня баг, и я сегодня его правил).
imported
Gena30.08.2005 09:20
Нет, не помогло.

<30>
Log started: Tue, 30 Aug 2005 10:13:00 +0400 (acWEB/3.0, build 6689, 16.08.2005)
Tue, 30 Aug 2005 10:15:33 +0400 MaxSPoolLen reached!
imported
Работает на Eserv/5.05555 (05.06.2016)