Регистрация...

Eserv Forum / E3 / Eproxy 3 Support / 3.34 -> 3.35 не стартуют acSMTP,eProxy

imported // (v1)
Продукты и услуги Скачать Документация Купить Поддержка Форумы Партнёрам Статьи О компании
Новости
12.10.2009
Переезд завершен
Добрый день !

Стал обновлять версию 3.34 до 3.35. Проводил все обновления как всегда.
После обновления не запустились сервисы acSMTP,eProxy.
Начинают запускаться — в *.log файлах видно, что сервис запускается и начинается работать. По *.txt логам видно что начинают обрабатываться запросы. А потом в системных логах:
The Eproxy service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.
и такое для acSMTP.
Нигде, ни в каких логах — ошибки не фиксируются.

Срочно пришлось "откатываться" назад на версию 3.34
 
Комментарии к этой версии (11.02.2009 12:34) [~ND] 2c7c569c
АвторДатаТекстtags
pig11.02.2009 13:02
Что-то с антивирусами? Там сейчас фишка забавная — сервис вроде как уже стартовал, а инициализация ещё идёт, и тормозит этот процесс именно антивирус (ну, может, ещё какие-то долгозапускающиеся плагины).

Нет, что-то не то... Был ускорен как раз запуск служб. То есть, запуститься она должна была успешно и быстро — а вот потом уже могут случиться неожиданные завершения...

Система у вас какая?
Попробуйте ещё вот это:
http://technet2.microsoft.com/windowsserver2008/en/library/611a83e2-02de-4f9a-996a-0022c4f2fbe31033.mspx?mfr=true
http://technet2.microsoft.com/windowsserver2008/en/library/303c786f-c627-457b-9553-162d3ec0a1241033.mspx?mfr=true
Я у себя увеличивал до минуты, когда однажды начались чудеса.
imported
ND11.02.2009 13:44
Система: Windows 2003 со всеми патчами и сервис-паками.

Попробовал увеличить время старта сервиса с 30 сек до 2х минут.
Пока сервис стартуется в течение 2-ч минут — всё работает. Затем опять ошибка в системных логах, и сервис остановлен.

Опять вернулся на 3.34
imported
ac11.02.2009 14:19
А сервис стартует под системной учетной записью или под специально выделенным пользователем?
imported
ND11.02.2009 14:37
Все сервисы стартуют под специально выделенным пользователем.
imported
ac11.02.2009 14:39
Лог acSMTP.log пришлите на support@eserv.ru, пожалуйста.
imported
ac11.02.2009 14:47
Спасибо, получил. Да из-за того, что не системной записью. Моя ошибка, затмение нашло, сегодня починю.
imported
pig11.02.2009 15:46
Только acSMTP, пожалуйста, соберите пока со старой версией hash-table, а то мои глюки вылезут.
imported
ac11.02.2009 15:58
Хорошо.
imported
ac11.02.2009 16:44
http://www.eserv.ru/download/server_exe.rar
Исправлен запуск сервисов.
Все exe кроме acWEB.exe собраны со старой версией hash-table. acWEB.exe с новой (для Dandy).

Вроде теперь конфликтов не должно быть. Если так, обновлю и дистрибутив.
imported
ND11.02.2009 17:01
С новыми версиями всё запустилось.
Только в логе eProxy.log появились такие строки:
Quota, begin new period: user3@domain ============EXPECT============ EXPECT100 Quota, begin new period: user1@domain Quota, begin new period: user2@domain ============EXPECT============ EXPECT100 ============EXPECT============ EXPECT100 ============EXPECT============ EXPECT100

Это результат неудачных попыток перехода или что-то ещё ?
imported
ac11.02.2009 17:27
Эти expect'ы должны были и раньше появляться, это не отключенная отладка редкой http-фичи. Влиять эти дампы ни на что не должны (и отключу). Интересно, что за программа работала в это время через прокси.
imported
ND11.02.2009 17:31
Раньше такое не появлялось.
Что за программа — не знаю, если бы можно было привязать этот expect к конкретному запросу из логов — тогда выяснил бы.
imported
Работает на Eserv/5.05555 (05.06.2016)